BeatMaker 2.6.2 has been released, with support of Ableton Link and improves the app stability. See http://intua.net for more information.

Using more than one external synth/drum machine

Hey guys

I have followed the instructions and advice on how to use external instruments in beatmaker by creating a midi track and track for the external app, however when I try and repeat the process using a 2nd external app, it doesn't seem to work...

Do I need to change some sort of settings to have more than one external app to be hard in beatmaker?

Comments

  • edited January 26
    Hey @BigDeezel,

    There are multiple ways of doing this. Basically you start by creating Audio Apps tracks, then as much empty keyboard sampler tracks. The order does not matter.

    Muting sequencer tracks
    No MIDI setup is required (unless an app doesn't read from channel 1 by default). Get in the sequencer window, and in the track header you will see a small "speaker" icon. Toggle it so the pattern is not read anymore. This way you can select which track will send notes to the external instruments.

    The MIDI way
    You properly configure each app with a specific MIDI input channel. Then, in BM2, you configure each empty keyboard tracks to output to specific output channels. You can do this by pressing the small "MIDI" icon next to the keyboard tracks thumbnail; the MIDI output setting is there. For example, you configure "App X" to listen on MIDI channel 1, "App Y" on MIDI channel 2, "App Z" on MIDI channel 3 and so on.

    The mute way (not the cleanest but pretty quick...)
    You just mute the audio track associated to the plugins, from the mixer. Apps will still receive MIDI data and process audio, so this is not really optimal performance-wise, but it can be quicker than the two aforementioned tricks.

    Hope this helps,
    Cheers,
    Mathieu
  • edited January 26
    Thank you Mathieu

    This app just seems to be getting better and better, so easy to use.

    I'm sure I'll have more questions in the future however for now that's perfect!

  • I've updated this, it was missing the use of the sequencer track mute.
Sign In or Register to comment.