IAA plugs crashing

edited December 2017 in Support

Hi. Trying to load AD 480, silkEQ, tone whatever, filtraton, makes no difference, BM3 says that it can’t load IAA plug. Not as bank insert, not as pad insert, and not as insert in an aux send either. Any thoughts Bm fam?


  • Regarding IAA Apps & Effects try to launch them before connecting them to BM3 as plug-ins and see if that helps.

  • Thanks for your suggestion. Sadly that did not help, but it got my hopes up for a second☺️

  • To be very precise, they don’t crash; I just get a message that they cannot load

  • I've only got (of the apps you mention) silkEQ and Filtatron and both those two work fine in BM3 on my Air 2, iOS11.1.2.

  • No problem loading AD 480, Silq, or Filtatron in BM3 here either. I don’t need to open them first or anything. Maybe post a screenshot of the message you get and list your iOS and iPad versions?

  • 11.1.2 iPad Pro
    First time uploading a pic on a forum so not sure if it worked but in a nutshell, it’s says: Can’t load AD 480 classic

  • I guess it worked. Hey, just wanna say thanks for trying to help y’all, I know the value of one’s time.

  • Hi again, I just deleted AD480 and redownloaded, bingo. I’m gonna do that with the other ones as well and l
    If that does not fix it all I’ll get back on the forum. I thank you both for your time. Really.

Sign In or Register to comment.