(FIXED in 3.0.13) MIDI Import transpose

edited October 2019 in Bug reports

Doesn't work full stop, it did work for me once, but nothing now at all
So if i set c1 to go to pad c3, nothing, it just goes to c1 still.



  • edited August 2017

    I'm having a tedious time trying to import simple midi loops. (Drum loops to test)

    Sometimes it imports ok, other times it starts at Pad 36 not 1 - using the same file and transposition map.

    The whole thing (midi file import) is a mystery.

    *** Am I a beta tester.. *** (feels like it)

    But my growing Love for BM3 outweighs most issues..


  • MIDI import works perfectly mostly, if the MIDI file is correct format, but the transpose just completely kills it, just totally useless
  • edited August 2017

    Yep, getting the files into the app is a breeze.

    Getting it to play/start on the correct note (e.g.; GM/C3 or 4) well.. needs work..

    As you say Transposition..



  • They play on the correct channel as per pad, but the actual notes cant be transposed on import, it did work once weeks ago, no idea what happened, but it needs fixing quickly, its impossible to import content
  • Also, changing the bank, deletes the midi in song view.



  • Not sure what that means ?
    You should start a new thread and explain the steps.
  • I'm having issues importing GM drum files , BM3 is importing Note# -1 ,
    so C3 in GM file is being placed in Pattern editor & played as B2 , F#3 as F3 etc.
    This is when importing with No Transpose .
    I'll have to change Pad note number as workaround , but this will need fixing .

  • @5pinlink said:
    Not sure what that means ?
    You should start a new thread and explain the steps.




  • @WallyBlo said:
    I'm having issues importing GM drum files , BM3 is importing Note# -1 ,
    so C3 in GM file is being placed in Pattern editor & played as B2 , F#3 as F3 etc.
    This is when importing with No Transpose .
    I'll have to change Pad note number as workaround , but this will need fixing .

    dOh ..aaaand of course I can't change pad midi note as workaround because as reported above it isnt working .

  • I think there are even deeper issues with midi import here , although with the bugs &
    the ( over ) complicated relationship of Pad # <>midi part <> sample maybe it's just me , but importing a GM drum file , not only is BM3 playing MidiNote 36 as Pad 37 , but when separating the other notes of the drum file onto the respective (+1) pad , it is also placing each note as C3 within the respective Pad's midi part editor . So e.g F#1 note is placed on Pad 43 ( it should be 42 ) but then within Pad 43 midi part it is placed as C3 !
    Not only is this confusing for editing , but playing the midi pattern via midi instruments it is transmitted as C3 . It requires manually transposing within the Pad midi part , placing as F#1 to be received as F#1 .

    Is this because setting Pad MidiNote number isn't working , as reported above ?
    I suspect it may be a different issue , related to Keys mode of being able to transpose the individual sample across the keyboard , presumably with C3 as base note .
    However , BM3 fails as a midi sequencer if a midi file loaded into a pattern cannot play the correct notes out .

    In the Banks/Instruments sequencer debate , this pushes me more towards requesting independent Instrument tracks , if midi loaded into a Bank is going to be mistranslated .

  • How did you import the MIDI ?
  • @5pinlink said:
    How did you import the MIDI ?

    Drag & Drop to empty Session Slot

  • edited August 2017

    I didnt mention my above findings were using GrooveMonkey GM midi files type 0 .
    They offer their Files in 3 GM formats , I have now tried them all with strange results .
    General Midi (GM)

    "These loops follow the general midi mapping standard. We provide 3 versions of our “gm mapped” loops with our full products:
    1) Multi-track - (each drum on a separate track and labeled). These are “Type 1” SMF (standard midi files).
    2) Single Track - These are “Type 1” SMF (standard midi files).
    3) Type 0 - These are “Type 0” SMF (standard midi files).

    I loaded same 1st file into 3 scenes in order shown in photo 1 .

    following photos show how (as reported in previous posts) Type 0 maps each Note in file to a Pad Note (incorrect +1 ) , but on opening the Pad's individual midi part the note is placed as C3 & the Pattern when played externally plays all notes as C (4! )

    MultiTrack file in Scene 2 correctly displays each note in the Pad midi parts & plays correctly all notes of file , but doesnt allocate each note of file to respective Pad number , instead loading the midinotes on Pads 2-6 .

    Single Track Type 1 give same results as Type 0 above so I won't repeat photos .

    Hope this helps & can be fixed @mathieugarcia

  • I'm glad i wasn't the only one trying all three MIDI file types from the same company and getting strange import results.
    Other MiDI files too. I also hope this gets fixed quick.

  • Hi everyone !
    @WallyBlo Thanks for your efforts and findings
    I just checked using our default GM transposition map and the free Type0 loops from GrooveMonkey and it appears to be working just fine.
    Did you use a transposition map? the GM one is needed in that case. (Create a transposition map, hit GM to set the defaults, save and import).

    Please also note that Type0 files will be translated to pads if the bank is in "PADS" mode, and to the selected pad mapping if "KEYS" mode is enabled.

    For Type1 files we've fixed an issue with the first track being a conductor/tempo track.
    If there's only one track after that, it will behave just as a Type0 file.

    If there are more tracks, for now at least, we split them on different pads starting the first one.
    We'll implement proper copy paste of events between PADS and KEYS mode so it will be more convenient.

    Please let me know if there's something I'm missing or if you need something else regarding the MIDI import feature. (It can get better for sure).

    PS: You can send problematic files if you want.

    Hope this helps,

  • edited August 2017

    Hey Vincent,

    Would be great to have a 'General Midi bank', unless there is one already.

    Import a GM file and all tracks are automatically configured and played with the correct (near enough) instruments.

    You did ask!

    (i) won't be able to give any feedback on the improvements til we get the 3.0.2.



  • edited August 2017

    Thanks for response @vincent , but the strangeness continues .
    I made a GM template , but saw no difference in outcome between loading the same Type0 midifile when in Pads or Keys mode ,
    & the GM template STILL allocates & plays each Note in each Pad midipart as C3 , which plays as C4 into MidiFlow Monitor . The differences using GM template is that the different notes are placed on first 4 Pads (similar to Multi type) but then there's a stray one on Pad12 , not attempting to match Pad number to midi number , but also now I notice each note is on a separate midichannel 1,2,3,4 & 11 !

    To doublecheck I have downloaded the GrooveMonkee free pack & repeated with the first file in Breakbeat folder . Exactly as above , whether loaded in Keys or Pad ( nothing selected ? ) it gives the same results as photos , except this time the stray note is on pad 27 ! , but still plays as midichannel 11 .

  • @vincent bump , maybe you missed my latest reply showing still problems

  • @vincent @mathieugarcia
    seems this has been overlooked again & now missed 3.0.2 .

  • edited August 2017

    @vincent @mathieugarcia

    I'm disappointed you ignored this issue as it was not resolved before , & is still not working in 3.0.2 it seems to me ,
    although I think Multi Track files now behave still incorrect but differently to reported above.
    Please find Dropbox link to zipped file of three types of GM file of same pattern .
    for Intua only please .
    https://www.dropbox.com/s/nuiq2zapbn6lyo3/BM3 GMfiles.zip?dl=0

    loaded with Bank in Pad setting I think ( nothing selected ) , using GM import template as before .
    (although you really should explain the difference as intimated above between loading in pad/keys in manual or tutorial I suggest .)

  • @WallyBlo
    I just tried with the 3 files you linked.
    I might be missing something but it seems to be working as it should (I agree it's not ideal for multi track files)
    Multi track file: import each track to a different pad, and uses the selected transposition map for each.
    Single track file: import notes using the selected transposition map, on the selected pad, if the bank is in KEYS mode, or on pads if not.
    Type0: behave the same as single track


  • @mathieugarcia
    While trying to test this out I am getting correct import info here, same as importing those files in to desk top apps.
    However there is an issue that i have tracked down that was reported elsewhere to, and i have found the cause.

    Some people are finding that imported MIDI is showing 0bytes and has no info contained within it, I seem to have rounded this don to MIDI files that are unzipped automatically by BM3, example..

    If i airdrop these three files as a zip and Beatmaker automatically unzips them to the import folder
    Single T and Type 0 contain no information at all, However if i airdrop them individually, they work fine.

  • edited August 2017

    @5pinlink gonna check this out right now, so I guess the ZIP posted via Dropbox in the last message triggers the 0 byte bug?

    EDIT: SingleT G-Funk 02 8-bar.mid is 853 bytes, Type 0 G-Funk 02 8-bar fill.mid is 808 bytes, imported on BM3 with the ZIP file, then back on my workstation. It's just the formatter bogusly showing 0 bytes. MIDI note on/off data is imported properly (no transposition template), however, the thumbnail doesn't show anything in the SONG mode (known issue), but the pattern has some notes starting pad 37+. Haven't checked MIDI channel yet.

  • @mathieugarcia

    No it is very intermittent, I have had it before and seen others report it too, some imported MIDI files have 0bytes and actually contain no information at all, it happened with two of these in the zip, when i unzipped on the desktop and sent, they worked fine, tried it with a few others, does seem to be the unzipping prcoess killing some MIDI files, but only some.

  • What happens if you import the files back to your desktop/laptop? 0 byte too?

  • Out for the night, will test first thing in morning and report back.

  • edited August 2017

    well I'm obviously missing something important here ( like a decent manual & tutorials , especially answering what difference Keys on/off makes to midi files )
    but those files are still not importing correctly for me using the GM import map .

    with Pads in Keys mode single & Type0 load to Pad number 1 and place the notes as
    (C C# D D# & B ) -2 .

    With Keys OFF , the notes are placed on pads 1-4 , + 10 +27 .
    each pad midi part places note as C3 , & the whole part plays as stream of C4 ,
    as shown in last photo of pad 3 which should be F# GM Hat .

    FTR loading file into Auria Pro gives correct GM mappings

  • I will double check everything again when i get home @WallyBlo

  • @WallyBlo The transposition map is mostly useful for importing without KEYS mode, remapping GM notes to the desired pads.
    To get the output like you have with Auria, don't use the transposition map, and put the KEYS mode on.
    Also I tried the MIDIFlow monitor app, I can confirm you that it displays the wrong notes (+1 octave), it's not a problem on the BeatMaker's side.
    I found an issue however when selecting "No Transposition", you need to discard the panel and re DND for it to be validated (already fixed here so in the 3.0.3)
    We will improve the panels though, I agree it's not clear that KEYS mode is for importing on one pad.


  • @mathieugarcia said:
    What happens if you import the files back to your desktop/laptop? 0 byte too?

    I can't get it to do it at all today, if i get a file that does it again, i will send it straight over

This discussion has been closed.