Tags missing after 3.0.1 to 3.0.2 update

edited September 2017 in Support

I spent a huge amount of time importing and tagging my samples into packs and categories a few weeks ago. I only now noticed that after the 3.0.2 update, when browsing packs and/or categories it appears that there are no tagged files.

I'm wondering, can a rescan of the database fix the links to the tagged files? The last time I did a rescan it took ages and that is why I am asking beforehand. Surely it can't be that the update from 3.0.1 to 3.0.2 would have cleared all my tagging? The names of the packs that I created are there as are the user created categories/sub-categories.


  • Hi @gosnote,

    Re-scanning will sure help. Meta-data is saved within sessions, bank presets and samples.

    Please keep me updated on this.


  • @mathieugarcia - thanks so much, the rescan worked! First time the rescan crashed but second time around it completed and now tags are working.

    Keep up the good work! BM3 is amazing and you guys are super responsive! Thanks to the forum community as well for the countless hints and tips so far.

  • Hello @mathieugarcia
    I'm currently having the same issue, I've had this app for almost 3 years and I've never had this problem so I'm a little bit confused. I need some help how do I re-scan?

  • @adhatt77
    It only came out just over a month ago, do you mean Beatmaker 2 by any chance ?

  • edited August 2017

    My mistake but to clarify, yes I'm talking about beatmaker 2. I'm still having the same problem though is there any way I can fix it?

  • Sorry dont have beatmaker 2 unfortunately

  • @adhatt77 BeatMaker 2 is quite a different beast on terms of tagging but:

    • Force-quit BM2 by double tapping the home button and swiping it up
    • Open the iOS Settings app, locate BeatMaker 2 in the list
    • Toggle "Reset database" and "Update database"
    • Restart BeatMaker 2: it will do a full re-scan of your content


  • @gosnote glad it worked! Avoid tagging AIFF files, there's a bug current but this is fixed in 3.0.3.

  • @mathieugarcia it worked! thank you so much.

Sign In or Register to comment.