Lots of trouble with plug ins

edited March 2018 in Support

I am new to Beatmaker3 and ipad music in general. I bought BM3 and Waldorf Nave synth which shows up as IAA plug in. I can load Nave to a bank but I don't hear any audio when I play it and I don't see any levels in the mixer. If I close BM3 and just run Nave stand alone it works fine. I was able to use Nave last night as a plug in and record audio in BM3 so I don't know what has changed. I have deleted the bank and set everything up from scratch several times and still can't get it to work and I have tried new projects. I can not hear audio out of Nave at all if BM3 is running, as soon as I quit BM3 the audio plays fine from NAVE. I also have a few IAA effects plug ins and I find that whenever I open a project that is using those plug ins it takes a long time to open the project and I get a window that says the plug ins have crashed.


  • First off IAA sucks, I personally avoid at all costs.

    But if you really want to use it, try running Nave before starting Beatmaker, that normally helps a bit.

  • Yeah, IAA apps do sometimes have problems, but that said, I just loaded Nave into BM3 and it just worked. Then I tried quitting BM3, quitting Nave, loading them back up, unloading the plugin in BM3 while it (Nave) was running, reloaded, etc in diff combos to try and replicate your issue - which I have had in the past with other IAA apps - but I couldn’t. It generally just worked fairly easily. So I’d recommend you unload/quit both BM3 and Nave, reboot your iPad, start Nave first, and then start BM3, and then load Nave onto a pad.

  • Audiobus 3 solves a lot of problems

  • edited March 2018

    Nave works great as an IAA in BM3 and BM2, no need to start Nave first though that is a good solution for AB apps that have partial IAA functionality. Are you able to load and hear Nave as IAA in any other IAA Host like AudioShare, AUM or Cubasis? Also which iPad and iOS version are you using?

  • I've had issues with this from time to time. I've noticed that, like ronji said, sometimes you have to start the app or plug-in first and then load it within Beatmaker... also sometimes if you hit a note on the keyboard in BM3 it kind of 'wakes up' the plug-in and it will run fine. Or, since you said you're not hearing any audio at all from Nave, if you're loading the plug-in in an audio track you won't hear anything unless you enable monitoring, which is done in the mixer window at the bottom of the track to the right of solo/mute.

Sign In or Register to comment.