When adding an FX plugin on an instrument, why BM3 skips to the next PAD when I play the keyboard?

I explain : if an instrument plugin is loaded on the first PAD of a bank and I add an FX plugin to this instrument, when I open the FX window, touching the keyboard makes the selection (which is on the first PAD , which has the instrument loaded on it) goes to the second PAD or the third one. Let’s say I add a filter to my synth on the first PAD of the bank and I enter the FX window, then to set my filter parameters I want to play a few notes on the keyboard while I turn the filter knobs, I have no sound because when I touch a key, BM3 select another PAD on the bank. So the only way to set my filter parameters is to press play and let the pattern play. But I can’t understand why touching the keyboard in the FX window moves the selected PAD. Most of the time the selection moves to the second PAD, but sometimes it’s the third or the fourth one. And it happens with every AU plugin FX but not the BM3 own FX. I think it must have something to do with MIDI but I can’t solve this strange behavior.
Do I sound crazy or does it speaks to you ? Thank you for your help

Comments

  • edited September 8

    @cyril777 I remember having similar issues, but I‘ve just tried out what you discribe and everything worked as expected. Do you have this problem in every session?

  • @denx said:
    @cyril777 I remember having similar issues, but I‘ve just tried out what you discribe and everything worked as expected. Do you have this problem in every session?

    Yes, every session, every bank, with every AU instrument or original BM3 bank (or from the store). I have this problem since day one, on 2 different ipad. I made a screen capture a few months ago to talk about it on the forum but I guess some other issues were more important for me. I think I can make a quick one now and upload it, so you can see what happens so you can reproduce it. The problem is obvious on a video....

  • I can’t find how to upload the screen recording I just made on this post so I put the link to the video :
    https://drive.google.com/open?id=1Sm__vobSpvv_Jv0mdMMjChAZIT8wQMEp
    here’s the description of what I do on the video but it speaks for itself....

    I load a filter plugin on a BM3 bank and switch to the FX window. First I just press play so you can see that the audio signal runs correctly, you see the waveform scrolling in Filterstation2 UI. Then I touch the keyboard and to play the bank but there’s no sound and no waveform. So I switch back to the performance window and unselect the key button so you can clearly see that active PAD is the fifth one, it’s blank so of course the keyboard can’t play the bank. This switch between PAD 1 and PAD 5 happens if you press any key from the keyboard (in FX window view). Then I do again the same thing 2 more time so you can clearly understand what happens.
    When the switch of PAD happens, it’s not always the PAD 5, most of the time BM3 switches to the PAD 2 or 3, but as you can see in the video it can be any other PAD. And there’s no relation between which key you press on the keyboard and the PAD which is selected on the performance window, so it’s really hard to understand what is happening here...

  • edited September 8

    Thanks for posting this.
    This bug always happens when adding any AU FX to any Bank, except Bank A.

    Irrelevant to this bug:
    FX plugin's classification, i.e. 'FX' or 'MIDI FX.'
    BM3 MIDI settings.
    FX lock icon status, etc.

    EDIT: Formatting; legibility.

  • @MSandoval said:
    Thanks for posting this.
    This bug always happens when adding any AU FX to any Bank, except Bank A.

    Irrelevant to this bug:
    BM3 MIDI settings.

    Thank you for paying attention to my post, and for your confirmation about reality of this bug. Good to know that midi is not part of the problem because this was my only lead. And while waiting for this problem to be fixed, there’s a workaround if you need to play the keyboard while tweaking your FX plugin knobs, it’s to tap on the square symbol (next to the name of the bank), like you do when you want to add a plugin to a single pad of a drum bank, and then select the first PAD to put your FX plugin.

  • @cyril777 said:
    ...And while waiting for this problem to be fixed, there’s a workaround if you need to play the keyboard while tweaking your FX plugin knobs, it’s to tap on the square symbol (next to the name of the bank), like you do when you want to add a plugin to a single pad of a drum bank, and then select the first PAD to put your FX plugin.

    Great workaround! Thank you!

  • @MSandoval said:

    @cyril777 said:
    ...And while waiting for this problem to be fixed, there’s a workaround if you need to play the keyboard while tweaking your FX plugin knobs, it’s to tap on the square symbol (next to the name of the bank), like you do when you want to add a plugin to a single pad of a drum bank, and then select the first PAD to put your FX plugin.

    Great workaround! Thank you!

    Can someone provide a screen shot or something of where this button is as am not sure which you mean. I posted this issue months back so would be cool if there’s a work around

  • @groovey
    It's convoluted, but do-able.
    Later, you may have to press the square symbol several times for the AU to appear?

  • @MSandoval said:
    Thanks for posting this.
    This bug always happens when adding any AU FX to any Bank, except Bank A.

    Irrelevant to this bug:
    FX plugin's classification, i.e. 'FX' or 'MIDI FX.'
    BM3 MIDI settings.
    FX lock icon status, etc.

    EDIT: Formatting; legibility.

    Ah, I only tried bank A 😏

  • @MSandoval said:
    @groovey
    It's convoluted, but do-able.
    Later, you may have to press the square symbol several times for the AU to appear?

    Holy shit it works ! I tried so many work arounds before and it was so frustrating. Such a small thing but a huge annoyance and now rectified through the wizardry of @cyril777 thanks ! And thanks for the clear explanation @MSandoval

  • edited September 10

    EDIT: n/a. (The UI became a slideshow will testing this, and I freaked out, but then remembered that I had recently transfered a few GBs of data on an almost-full disk. My bad.)

Sign In or Register to comment.