BM3 buffering it seems :-(

Hey guys this morning on the train I was playing with BM3 and I loaded some IAA apps one was FM Player and the other Arp Oydessei. The Arp app started to buffer and the audio started to glitch when I play. Its quite worrying because I'm using two apps and it seems that the whole system couldn't handle it!! I'm using Ipad 9.7 128gb just in case wondering. Thoughts welcome.

Comments

  • Worth noting is that Arp Odyssei is a CPU hog especially when using smaller buffer sizes.

    FMPlayer can tax the disk as it always streams the samples .
    For DX7-Type sounds KQ Dixie might be an option. It's very easy on the CPU and reads DX7 SysEx files.

    Personally I'm staying as far, far away from IAA apps as I possibly can...

    There's always the option to use Arp Odyssei in Gadget, sequence & render the tracks there and import them to BM3 via AudioShare.

    Wether we like it or not on iOS it's sometimes worth to invest time in finding work-arounds or alternate apps that do the job.

  • Wow that's quite bad that my Ipad can't handle a few IAA at the same time. Perhaps I have chosen CPU hungry ones but still I'm really dissapointed!! :neutral:

  • edited September 11

    Here's my summary

    1. Your iPad is fine, and should be plenty powerful (which version 9.7" do you have?)
    2. Arp Odyssei is particularly CPU-heavy, even in Gadget.
    3. (and most importantly...) IAA is flaky as shit and should be shot in the face
  • @tk32 said:
    Here's my summary

    1. Your iPad is fine, and should be plenty powerful (which version 9.7" do you have?)
    2. Arp Odyssei is particularly CPU-heavy, even in Gadget.
    3. (and most importantly...) IAA is flaky as shit and should be shot in the face

    Thanks I'm going try getting some AU apps soon and see how that works. I have the 2017 version of 9.7" Ipad.

  • Check your audio buffer in B3 settings. I've got mine set to 1024 to help prevent issues like this, on my 2015 iPad Pro.

  • edited September 11

    Can't find the Audio Buffer settings in BM3 - really strange. :neutral:

  • @ronji said:
    Check your audio buffer in B3 settings. I've got mine set to 1024 to help prevent issues like this, on my 2015 iPad Pro.

    Thanks - found it. I'll see how that goes. Cheers mate.

  • @The_Bro said:
    Wow that's quite bad that my Ipad can't handle a few IAA at the same time. Perhaps I have chosen CPU hungry ones but still I'm really dissapointed!! :neutral:

    Strange, I have ODYSSEi and FM Player running as IAA Instruments and 4 AU instances of iSEM running at a 256 Buffer with no glitching. CPU occasionally hits 74% on my 2017 9.7" iPad aka iPad 5. I am still on iOS 10.3, is iOS 11.4 that inefficient?

  • edited September 11

    More than likely a ghost IAA, or IAA glitch-out issue

    You'd probably find if you restart the iPad and reload the project all would be fine

  • On that note, it would be a good idea to reboot the iPad. You could also suspend all apps out of memory by holding the power/sleep/wake button till you see "slide to power off" and instead of slide just hold the home button till you're returned to the lock or home screen. Rebooting should accomplish the same thing, but takes longer and might be more appropriate in certain circumstances.

  • edited September 11

    I put the audio buffer to 1024 and that seems to have fixed it!!

  • edited September 11

    Glad you fixd it @The_Bro

    Does that mean you'll be entering this month's battle (all entries must be PM'd to 5pinlink by midnight this Sunday)?

  • @tk32 What's this month's battle lol? What style lol?

Sign In or Register to comment.