Samples drifting out of time???

So I have a bassline sample from a tune and for the first few bars its fine then it starts to drift out of time then when it goes back to the beginning of the loop its fine. Any thoughts??? :-(

Comments

  • edited January 4

    How long does the sample last (in bars)?
    Are you re-triggering it at the start of each bar/phrase?

    ...could you post a short video showing how the song is setup?

  • I will mate. It's basically just a sample in an audio channel on its own. I can do a video over the weekend and post it up on Instagram or something. Not sure else where I'd put it though.

  • edited January 4

    OK - my suggestion is to load the audio sample into the BM3 sampler, and then use a midi note to restart the loop every time you need it to begin again (for example, every 4 bars?).

    Even if your tuning/timing is slightly off, you are re-triggering the loop on a downbeat each time so it will cover up any tiny timing issues

    if you load the audio into the sample you are also free to adjust the fine-tuning too

  • Just slice it in to bars, then trigger each bar in a sequence, sample slicer will do this automatically in seconds.

  • I've done that and it still drifts out of time. I thought BM3 was all about sampling. :-( This wouldn't be an issue on BM2.

  • edited January 4

    @The_Bro

    I'd like to see some video evidence of this. I still don't really understand what you mean by samples drifting.

    There's definitely nothing wrong with BM3's sampling, in my experience. Prove me wrong!

  • Just put the exact same sample in BM2 and its perfectly in time. I'll do a video mate.

  • edited January 4

    Will be very interested in this video too, I havent come across this issue, Ableton Link isn’t turned on is it ?

  • @5pinlink said:
    Will be very interested in this video too, I havent come across this issue, Ableton Link isn’t turned on is it ?

    No Ableton link is off. ☺

  • Well there shouldnt be any pitch or tempo modulation by simply playing a sample, when you make the video can you show the modulation tab just out of interest.

  • Well, this is really becoming quite the big mystery @The_Bro :)

    A sample that drifts in BM3 but works fine in BM2

    There has to be some logical explanation, me thinks!

    Can’t wait to see your video, can’t you do it now on your phone? The suspense is killing me :)

  • BTW @The_Bro when doing a video you don't want to post to your main social channels like instagram, you can either just share the video via Dropbox, or upload the video to YouTube and set it as unlisted, and only folks who have the link will ever see it in both cases. You can always delete the videos later once they're no longer needed.

  • Also, you could share the sample in question here and I'm sure several of us will be happy to test with it.

  • edited January 5

    Love having @ronji as the voice of reason

    Yeah, please post the sample here too @The_Bro - if this is a bug we all want to squash it!

  • @The_Bro said:

    @5pinlink said:
    Will be very interested in this video too, I havent come across this issue, Ableton Link isn’t turned on is it ?

    No Ableton link is off. ☺

    This was an issue in bm2 am not sure how it’s an issue for bm3 and not for 2 for your experience. To me it’s not really an issue it’s just there was no way of dealing with an intended outcome. I suggested sample warp option a while back but it wasn’t well received for I guess fair and various reasons.

    Haven’t been on 3 in a while but am definitely gonna get a track to sample I know will drift and see if there is ANYWAY possible to manipulate it within bm3. Thing is most daws have some way to deal with this nowadays explicitly. Bm3 not so much if at all. I’d get them but I Love BeatMakers interface and workflow capabilities and I hate computer BASED production.

    KYOKU on YouTube has a video called ‘how to sync samples that are not on beat to tempo’ I think this video sums up your issue. Peace

  • I’ve had issues with this today while I was working on this month’s challenge. I posted a few vids in the discord. Funnily enough, it only drifted when I pitched down the sample. If it remained at it’s natural tuning, I could time stretch with no issues. Another weird glitch that was occurring was the sample would jump randomly to another section when I cut it on the timeline after I had performed the repitch. Perhaps @mathieugarcia could offer some insight on this issue.

  • The sample is in time for the first bar but then it drifts out of time and then comes back in time again at the beginning of the loop.

  • @The_Bro said:
    The sample is in time for the first bar but then it drifts out of time and then comes back in time again at the beginning of the loop.

    Yes that's what happens

  • @Thumpee said:

    @The_Bro said:
    The sample is in time for the first bar but then it drifts out of time and then comes back in time again at the beginning of the loop.

    Yes that's what happens

    Mm I think its a BM3 glitch because I had no issues with the same sample in BM2. :smile:

  • @The_Bro said:

    @Thumpee said:

    @The_Bro said:
    The sample is in time for the first bar but then it drifts out of time and then comes back in time again at the beginning of the loop.

    Yes that's what happens

    Mm I think its a BM3 glitch because I had no issues with the same sample in BM2. :smile:

    if you post a video then people can help

  • As @theinvisibleman says.. we can't really comment or help any more with this request until we either see a video or detailed description of exactly how the session and sample is being used.

  • edited January 8

    I am very new to BM3 and I also thought I had a sample drift issue... I found out it was human error on my side in the end.. eek! Quickest way is to send a video of the issue and these OCD members will be on it in a flash.

  • Indeed.

  • Indeed indeed. Also @The_Bro are you sure the sample lined up correctly? Or just post the video. Someone else was having similar issues and it came down to user error.

  • Come on guys this isn't the first time I've used samples lol. It don't work for me in BM3 but I will try and post a video. ☺

  • We’re very keen to help, but we need to know more about what is going on in your track.

    A detailed description might do it, but a short video is quicker and easier

  • Can you just export the project and upload it? Then everybody can test exactly what you are.

  • @The_Bro said:
    Come on guys this isn't the first time I've used samples lol. It don't work for me in BM3 but I will try and post a video. ☺

    It happened to me and I use a lot of samples. Where I thought the vocal match with the downbeat was incorrect. Ain’t nothing wrong with making a mistake.

Sign In or Register to comment.