Making a loop fit one bar perfectly

This should be simple but..... I have a breakbeat sample whose BPM is 120. When triggering as a loop on the pad view it loops perfectly. When I add it to the song view the sample extends just beyond one bar so the loop is cut off early. I've tried timestretch etc but nothing appears to resolve the issue. Any tips?

It must be something simple but its driving me loopy :-)

Comments

  • edited January 28

    Are you dragging the audio file onto the timeline, or triggering it via a midi pattern?

    My advice is to do it the second way ;)

  • edited January 28

    Your BPM of the sample is actually slightly out, so it is probably 119+ BPM, not 120, at those sorts of BPM differences, live stretch will add next to zero artefacts, press edit or double click on the sample, press BPM, press calculate, press OK, turn on livestretch, return to arranger.
    That should lock the loop in tighter than a ducks backside ;)

  • @winconway said:
    Your BPM of the sample is actually slightly out, so it is probably 119+ BPM, not 120, at those sorts of BPM differences, live stretch will add next to zero artefacts, press edit or double click on the sample, press BPM, press calculate, press OK, turn on livestretch, return to arranger.
    That should lock the loop in tighter than a ducks backside ;)

    Thanks mate but no cigar. Sample always ends at 3.75 on the song grid within 1 bar no matter what. Tried adjusting BPM and calculating......... Weird

  • A guy on the audio us forum nailed it. Manually adjusted sample BPM to 170 and bingo. Used an online BPM calculator and the samples number

    http://amusicproducer.com/bpm-calculator.html

  • Care to share the sample via Dropbox and someone can figure it out? Are you 100% sure that this break beat is 120 BPM, or are you assuming BM3 detected it as that? Reason I ask is cuz in BM3 currently defaults the BPM of all samples to 120, until you change it in a session as @winconway was describing.

  • edited January 28

    Yeah, I’d love to see a copy of the sample too. There are some real knowledgeable (and helpful) cats on this little forum, but they can only help based on what you give them :)

  • @ssspla said:
    A guy on the audio us forum nailed it. Manually adjusted sample BPM to 170 and bingo. Used an online BPM calculator and the samples number

    http://amusicproducer.com/bpm-calculator.html

    I missed this reply. Glad you got it figured out! However the calculate tempo function should work if your sample is perfectly trimmed as you described, just need the correct number of beats. For example, I have some drum breaks that are 172 BPM, 4 bars long, but the sample has a full bar of silence at the end, so calculate doesn't work until I change the beats from 12 (?) To 20. I have another break beat that's trimmed perfectly to 8 bars, it's 172, but calculate tempo detects 4 bars (16 beats) at 86 BPM. I just use the X2 button to double that to make it correct. Even the tool on the site you linked needs similar info to get the right value.

  • Aaaaaagh they helped him on the Audiobus forum to ignore my advice, and now he is usong an external webpage instead of just hitting calculate lol.

    Its a 170 Tramen (FYI myself and @ronji are nutso for DnB) so just hit calculate under the bpm settings.......wait didnt i do a video for this ?

    Watch that lol

  • edited January 28

    I was about to enquire if Win was such a breakbeat freak he could actually ID them by sight alone...

    ..then I realised the OP’s screenshot on AB forum was named “Tramen breakbeat.wav”

    Doh!

Sign In or Register to comment.