Two major, consistent bugs

So I’ve been having two consistent issues with BeatMaker 3 and I don’t see others experiencing them so thought I would report here:

If the app has been idle for a bit, and I open it up, as soon as I go to add any sort of plugin, the app crashes. As soon as I re-launch it and add a plugin, it’s fine until I let it go idle again. But it gets very annoying to have to relaunc the app basically every time I go to add a plugin.

Second, and far more annoying: every time I stop audio playback, BM3 forgets my CME Xkey Air is connected via Bluetooth. The keyboard is powered on, ready to be paired again immediately, but each time I press stop I have to go back in and reconnect to it. This doesn’t happen in any other app so I don’t believe its a problem with the Xkey. And I could always play over a loop, but with a full track you sometimes want to “jump” in at the appropriate time, and if you miss it you want to stop and rewind it back.

For what’s it’s worth: I’ve got a 2018 11” iPad Pro, the latest and greatest. This thing is an absolute beast and should definitely be able to handle this without any issues.

Comments

  • I can confirm that I have the CME XKey Air BT disconnecting problem as well.

  • edited February 27

    Strange. I don't have the CME, but my Korg Nanokey studio uses Bluetooth midi and stays connected to BM3 just fine.

    I know that Henny uses the CME all the time... I'm sure he would have posted here if this bug was affecting him.

  • Disable Xkey MIDI out in B3s prefs, that fixes it ;)

  • I have the xkeybair and can confirm disabling the midi out fixes the problem.

  • Thanks for the help on the midi issue everyone!

    Now if it would just stop crashing when I load plugins I’ll be in business lol.

  • Not sure what other people do here, but I almost never let BM3 sit idle in the background for any long periods of time (mostly because of the high battery drain)

    My habit is to save and then force quit between music making sessions, and I never have trouble relaunching plugins — but then again, I only stick strictly to AUv3.

  • @tk32 said:
    Not sure what other people do here, but I almost never let BM3 sit idle in the background for any long periods of time (mostly because of the high battery drain)

    My habit is to save and then force quit between music making sessions, and I never have trouble relaunching plugins — but then again, I only stick strictly to AUv3.

    I haven’t experienced much background battery drain with BM3, but I’ll take this in to consideration!

    I pretty much strictly use AU at this point as well. iAA is just clunky and I’ve had an incredibly difficult time wrapping my head around AudioBus. Too much fiddling.

    Thanks for the tip!

  • I have had crashes when just simply pulling up the plugin list, I think when selecting AUv3, before the list populates. I hadn't thought much about it before but I think it was after idle time. I thought it might have been related to having several things loaded in the session and latency set "low" at 256. At those times I will take latency up to 512 or 1024 to get the UI to stop being sluggish and things are generally much more stable. Dunno if this is a resources issue or something that can be improved in BM3

Sign In or Register to comment.