BM3 Session corrupting?

So I’ve spent a few days getting the feel of BM3. Ive done 6 quick sessions so far. The last one seems to have corrupted though. It seems to load up fine. I presss play and then nothing happens. If I try and load another session nothing happens.. If I restart BM3 the other sessions will load and play. In the corrupted session I only used AUV3 instruments. FM Player 2, Syntronik, and two instances of SynthMaster One.

I have been searching the forum here. I saw that sessions can corrupt if BM3 closes while saving etc. Mine didn’t close while saving so I’m not sure what’s happened. Are corrupted sessions recoverable? The session I did was just a quick one, so it’s no big loss but it is worrying for future projects. Thanks!

Comments

  • Sounds like some bad luck you’re having here.

    If BM3 doesn’t say the project is corrupted, then there is a good chance it isn’t. If the project really was corrupted, BM3 would give an error message during load.

    Have you tried restarting the ipad? My tip is to start BM3 after a fresh reboot, load the project and then wait about 10 seconds while all the plugins finish loading.

    Sometimes if you try to start playing the project before all the plugins have loaded it kinda gets stuck in limbo, and you don’t get proper sound (similar to what you mention above)

  • ctecte
    edited April 15

    Thank you.

    Yes, I tried rebooting my device. I tried loading the session and leaving it for 1 min but it still doesn’t work. I don’t get any messages about corruption. It “appears” to load normally until I try playing an instrument or pressing play. I’ve tried loading it and then saving it as another name but it just gives the “saving” message endlessly. Once I press play, those butttons seem to lock up (play, stop, etc) but I can still switch to different parts of BM3, like the mixer, and change the channel volumes. It essentially locks up BM3, leading me to quit and restart the app.

  • edited April 15

    I’m tempted to say it could be the fault of FM2. The audiokit AUv3 plugins are still quite buggy.

    Could you upload a copy of your project here so I can try to open it?

    Another thing to try is...
    1. Open the project
    2. Delete bank A
    3. Try playing
    4. Repeat steps 1-3 for each bank in the project (just don’t hit save once you’ve deleted anything)

    If deleting any of the banks works, ‘Save As’ with a new session name.

  • I tried to delete each bank but it won’t let me.

    Here is the session link:

    https://dropbox.com/s/p80ykgj6bofzdje/Session%20Apr%2015%202020%5B001%5D.zip?dl=0

    Thank you for trying it!!

  • Good news! The project opens and plays fine for me.

    The only difference, I don’t have Syntronik, so that bank remains silent.

    Did you try increasing your buffer settings to 512? It may help

  • Thank you again for your help.

    I have deleted Syntronik and changed the setting to 512 but it still doesn’t work for me. I deleted the project, rebooted the device, rescanned the BM database and then downloaded the project I uploaded but that didn’t work either.

    Really strange that it’s working for you but not on my device. I’m hoping now that synthtronik is gone it won’t happen to other projects in the future.

  • edited April 16

    I've been on this forum since BM3 first launched, so I can say with confidence that these sort of problems with sessions are extremely rare,

    The main risk is force-quitting during save, or letting your battery die while you have a project open - and you don't do either of these :)

  • I will keep that in mind. :)

    Can I also pick your brain on a related subject? I am trying to un learn my BM2 ways. BM3 seems different in nearly every way to me. In BM2 I would start a project and then every 30 mins or so I would save it with a different number eg: “SongTitle1”, “SongTitle2”, “SongTitle3” etc. I would do this In case of file corruption. I would usually end up with 20 incrementations of the project file all contained within the same project folder. BM3 doesn’t seems to do that. It creates a new folder each time I do “save as”. Is there any way to save into the same folder other than manually moving the files afterwards?

  • edited April 16

    I have those AUs. Was bored so...
    1. Opened your session, CPU in the red (>100%), waited a minute, CPU still in the red.
    2. FMP2 and Syntronik GUIs won't open; Syntronik doesn't even show its icon in the 'PLUGIN' tab.
    3. Unmuted all muted tracks.
    4. SM1 x2 GUIs do open, but no sound.
    5. No sound out of any tracks, even the audio track.
    6. Deleted Syntronik track, FMP2 immediately crashed.
    7. Deleted FMP track.
    Now the session plays. CPU ~16%.
    8. Closed BM3, opened BM3.
    9. Open your session again, it works this time! Well, Syntronik won't load and its icon still isn't visible. But FMP2 plays fine. CPU ~20%....then jumps to >100% !!! Now it won't play. No sound.
    10. Closed BM3, opened BM3.
    11. Tried to recreate your session from scratch - no issues. FMP2, Syntronik and SM1 x2 are fine. CPU ~25%.

    A. Syntronik and FMP2 are both sample-based, could it be an instantiation and memory issue?
    B. Syntronik had an issue were the sample rate wasn't following the AU host. This was a bigger problem on the 2018 and 2019 iPads that are locked at 48kHz when using onboard audio. There was an update about 10 months ago that addressed this, but since then, I haven't had a 2018 or 2019 iPad to verify. Plus I don't know which iPad you're using. I'm using a 2017 iPad Pro 10.5 @ 512 samples latency.

  • Oh wow. Ok. Thank you for that! I am also using an iPad Pro 10.5 2017.

    It’s pretty much identical to what I experience except no matter what I try, I am unable to delete any of the tracks. The CPU constantly reads 0% too. I think I am just going to keep Syntronik off my device and hope this doesn’t happen again. Maybe when I downloaded some of the extra instruments from inside Syntronik, there was an issue with corrupted files or something.

  • ctecte
    edited April 28

    The same thing has happened to me again on a different project. I was using 3 tracks: a sampled beat + 2 instances of FM Player 2. I was playing the keyboard on the second instance of FM P2 and it suddenly crashed. Then BM3 crashed. I tried to load the project and it’s locked up again, exactly the same as in my first post. I’ve reinstalled FMP2 but the track is still dead. Another track lost. 😩 Arg. I have lost confidence in BM3. It really makes me feel like ditching it and going back to BM2.

  • FM player 2 has known issues as an AUv3. The developer has acknowledged this and is trying hard to improve their code, but for now I would suggest caution when using them (in any host, not just BM3).

    I know it's frustrating to lose work - it's happened to all of us at one time or another - but perhaps don't be so quick to blame it all on the host. All modern DAWs on iOS that support hosting AUv3 plugins are also known to crash occasionally. Unfortunately, when working with plugins there is no such thing as crash free yet

  • ctecte
    edited April 28

    Thank you tk32.

    I’ve found it quite difficult migrating over to BM3. Nothing is where I expect it to be and some other stuff I just can’t find lol. 😂 The AUV3 has been the most fun new feature for me. BM2 used to crash every now and then but I could always reopen my projects afterwards. AUv3 crashes, that corrupt projects, is something I am not used to and is certainly a worry for me.

    By chance, do you know if any of the other AudioKit apps (like synth one/bass 808) have similar problems? I will stay away from FMP2 AUv3. Thanks again.

  • all the audiokit plugins are suffering similar issues, I'm afraid.

    We're all hoping the dev gets the issues resolved soon, as these are really great sounding apps.

  • I see. I will steer clear for the moment. Thank you!!

Sign In or Register to comment.