Funk Drummer and BeatMaker 3 compatible?

I can’t get Funk Drummer app to work inside BeatMaker. I can load it as a plug in but I can’t get the pads to trigger the sounds inside Funk Drummer in “Sound Module” mode or get it to start/stop a pattern inside Funk Drummer. I have been able to use other drum apps inside BM3, and Funk Drummer see’s my launchkey’s pads as triggers, and starts and stops playing when using Audiobus and GarageBand.

What is the big mystery between these 2 apps? It must be on the BM3 side as other sound modules work without any fuss. I have done all for he obvious midi settings. Channel 10, note mapping, etc...

Help?!

Comments

  • Disable Link in Funk Drummer to get it to start and stop with BeatMaker.

    I was unable to get it to work in sound module mode.

  • Thanks for the response! I did get Funk Drummer to start and stop, only with Ableton Link on. However, the audio of Funk Drummer is not coming through BM3. It play is the background The fader shows no signal and has no effect. So odd. Ugh. I depend on Funk Drummer. :(

  • @cgdream said:
    Thanks for the response! I did get Funk Drummer to start and stop, only with Ableton Link on. However, the audio of Funk Drummer is not coming through BM3. It play is the background The fader shows no signal and has no effect. So odd. Ugh. I depend on Funk Drummer. :(

    It works fine here. Are you loading it into a pad in a bank? The sound isn’t going to come through BM3 unless you do that. You also need to tap the app icon in BM3 and open the app at least once.

    When you’ve loaded it into a bank on a pad, you do need to disable Link to get it to start and stop with BM3’s transport.

  • Still not working. :( I create a new bank, select load plugin and load Funk Drummer. Select the plugin tab, press the Funk Drummer icon to load it, turn off Link go back to BM3. Still no audio or start/stop. Is that the same as “loading funk drummer onto a pad”? Ugh!

    @number37 said:
    It works fine here. Are you loading it into a pad in a bank? The sound isn’t going to come through BM3 unless you do that. You also need to tap the app icon in BM3 and open the app at least once.

    When you’ve loaded it into a bank on a pad, you do need to disable Link to get it to start and stop with BM3’s transport.

  • edited May 1

    @cgdream said:
    Still not working. :( I create a new bank, select load plugin and load Funk Drummer. Select the plugin tab, press the Funk Drummer icon to load it, turn off Link go back to BM3. Still no audio or start/stop. Is that the same as “loading funk drummer onto a pad”? Ugh!

    @number37 said:
    It works fine here. Are you loading it into a pad in a bank? The sound isn’t going to come through BM3 unless you do that. You also need to tap the app icon in BM3 and open the app at least once.

    When you’ve loaded it into a bank on a pad, you do need to disable Link to get it to start and stop with BM3’s transport.

    Does Funk Drummer show up in Settings > Audio and MIDI Devices > Output, and is it enabled there?

    Edit, it also seems to work fine for me with Link now. I just didn’t realize I had Link disabled in BM3.

  • Yes, FD is showing up in MIDI settings, Output is enabled. With Link on FD does start/stop. I can hear FD because it’s playing in the background but the audio is not coming into BM3. Nothing on the Fader.

    This is killing me as i bought BeatMaker for the sole purpose of using Funk Drummer in a performance situation. If you are getting audio through BM3 do you think you could post a project file on Dropbox or somewhere? There aren’t many settings to play with so I’m truly stuck.

    Thank you for trying to help!

    Does Funk Drummer show up in Settings > Audio and MIDI Devices > Output, and is it enabled there?

    Edit, it also seems to work fine for me with Link now. I just didn’t realize I had Link disabled in BM3.

  • https://www.dropbox.com/s/0httn4be4zvpwm1/Funk Drummer Test.zip?dl=0

    I did nothing special. Just created a new project, tapped a pad, loaded the plugin, opened the app, returned to BM3, and pressed play.

    Are you using an external interface? I’m just using headphones in the headphone jack.

  • edited May 2

    Sorry, have to ask ... have you tried rebooting you iPad?

  • edited May 2

    I downloaded you BM3 file, thank you for doing that.

    Your file also shows that Funk Drummer is NOT coming into BM3, it’s just driving the start/stop. No Funk Drummer Audio is coming into BM3, which is useless to me.

    When you look at and use the mixer on the Bank with Funk Drummer It is dead right? No audio signal is seen in the fader in the mixer right?

    I need to be able to record live loops of bass and guitar and mix Funk Drummer with it. Funk Drummer playing in the background will not work. I need to mix the drums, mute them, etc... switching apps everytime I want the drums to start and stop is beyond useless. So sad, waste of money in BM3.

  • edited May 4

    @cgdream said:
    I downloaded you BM3 file, thank you for doing that.

    Your file also shows that Funk Drummer is NOT coming into BM3, it’s just driving the start/stop. No Funk Drummer Audio is coming into BM3, which is useless to me.

    When you look at and use the mixer on the Bank with Funk Drummer It is dead right? No audio signal is seen in the fader in the mixer right?

    I need to be able to record live loops of bass and guitar and mix Funk Drummer with it. Funk Drummer playing in the background will not work. I need to mix the drums, mute them, etc... switching apps everytime I want the drums to start and stop is beyond useless. So sad, waste of money in BM3.

    Incorrect. For me the sound is most definitely coming in to BM3. I see the levels move and I can record the audio to an audio track as well as sample it inside BM3.

    This has to be something about your configuration. You didn't answer my question about whether you're using an external interface or not and whether you tried rebooting the iPad. These things may help narrow down what is going wrong. Knowing your iPad model and iOS version may help as well. On a long-shot, you might want to try changing Measurement Mode in the settings just to see if it has any effect. I've no reason to think it will help, but it's easy enough to try.

    The is almost certainly a solution to this issue if you have the patience to work through it methodically.

Sign In or Register to comment.