BM3 keeps on loosing samples, how can I avoid that?

24

Comments

  • @roman_che said:
    What audio source did you use for recording your samples? I have thoughts...

    Sampling vinyl through an Arturia Audiofuse interface.

  • edited January 23

    I converted the samples I wanted from mp3 to 44k 16bit wav.
    The total space for all samples incl drums is around 30gb and the samples that are gonna be sliced are separated in two folders, one containing 499 samples and the other one around 100 samples..

    If I remember correctly you can put 500 files maximum in one folder in ios, is that what you are thinking about?

  • And you can even open your beats after 10years and they will load:) I think this won't be possible on a pc/mac/ios^^

    @pask74 said:

    @estebano said:
    I have exactly the same and I don't know how to reload the beats with the sample/chops missing. This is at maybe 25% of all beats. Another big part of my beats just make bm3 instantly crash when trying to load them. That whole "making beats on an iPad" thing was a waste of time for me. Really looking forward for the new mpc!

    I need to admit that I’m very close to getting a good ol’ MPC4000 and keep the iPad for hobby activities instead.
    The last thing I want in my creative process is the stress to never know if things are lost or corrupted, etc.

  • @pask74 said:

    @roman_che said:
    What audio source did you use for recording your samples? I have thoughts...

    Sampling vinyl through an Arturia Audiofuse interface.

    @pask74 said:

    @roman_che said:
    What audio source did you use for recording your samples? I have thoughts...

    Sampling vinyl through an Arturia Audiofuse interface.

    Thanks for the answer. > @pask74 said:

    More error messages this morning:
    Sample not found: /var/mobile/containers/data/application/91

    Any idea?

    I have some ideas about this point. I remember a very long time ago, once I catch something like this, but I need to test. I remember this message about a file missing in some /var/...blah-blah place. I will do some tests today and tomorrow.

    Hope we will catch this bug. I think this may be related to the source of the recording (I don't sure, will look).

  • @estebano said:
    And you can even open your beats after 10years and they will load:) I think this won't be possible on a pc/mac/ios^^

    Guys, please :) Every device has its pros and cons. Hardware problems and losses can be frustrating. I say this as a person who has worked with electronics and repairing it for a long time ;)

    Of course, Apple and its politics for iOS has some annoying sides. I agree.

  • @roman_che said:
    I will do some tests today and tomorrow.

    That’s much appreciated, thanks.

  • More lost samples whacky behaviour today:
    https://streamable.com/k3j2t

    Sample was lost (and so is all the slicing job...), I reloaded it manually and now it plays (in its raw form, no slices) although it’s considered lost by BM3!

    I guess it’s time for a clean and robust files management manual section, too.

  • @pask74 said:
    More lost samples whacky behaviour today:
    https://streamable.com/k3j2t

    Sample was lost (and so is all the slicing job...), I reloaded it manually and now it plays (in its raw form, no slices) although it’s considered lost by BM3!

    I guess it’s time for a clean and robust files management manual section, too.

    Can you please post the screenshot where I can see the full filename path? I mean this path /var/../.././ etc
    ?

  • Here you go

  • @pask74 said:
    Here you go

    oh my ..
    Thanks.

  • edited January 23

    @pask74 I haven't been able to catch it yet.
    I thought that during the recording process from external sources, BM3 saves some files in a temporary directory. Now I recorded few samples with IAA + AUM + BM3, but everything seems ok. (after restart, save, "save as", it works).

    But I think it has to do with some way of recording sound. I guess.
    I still testing.

  • @Digital_Midgets said:

    @hansjbs said:
    We need to figure out what’s going on. Are you guys editing the samples (change start and end)? After you chop as you using the “save slices as”. I’ve been using BM3 since release and I do a save sessions with a samples and never have this issue.

    I usually chop samples manually. Copying and pasting and always do Save session with samples every time.

    Doesn't matter if chop manually or not. After chops are they being save? The chops needs to be saved after you chop and placed in the bank

  • @pask74
    Wait. I see all this lost samples were Edited, right?
    You have this problem with Edited samples only, right?

    It was a long time ago, and I lost a sample that I wrote through AUM. In the end, I didn't find it, but since it was an Edited sample (numbered like [003]), the old version with lower numbers was in Samples folder.

    Hmmmmm! :#

  • edited January 23

    @pask74
    Try to save samples after editing. It is the "Save" Button near the "Slice mode" button.![]
    @hansjbs looks like I say about the same

  • Thanks for your persistence, guys.
    I’d like to avoid samples duplication etc., this is why I don’t save the samples separately once chopped, should I?
    2 out of 3 of my projects open just fine without doing it.

    Also, I found a video in the resource section explaining how to manage files and I’ll make sure I follow these instructions by the book and report here.
    The author also finds BM3’s file management whacky, though.

  • More (bad) news: I’ve just loaded a project from 2 weeks ago containing strictly imported drum sounds without any « + » in the name. All lost!

  • @pask74 said:
    More (bad) news: I’ve just loaded a project from 2 weeks ago containing strictly imported drum sounds without any « + » in the name. All lost!

    @pask74 sad to hear that, it is really frustrating. Seems like it is not a filename problem, but the problem of unsaved edited Banks. You need to save a sample after you chop it, and after editing. Seems like BM3 temporary saves samples in /var/ directory, until you save The Bank. It is necessary to do: You slice, or you edit, then save the Bank include all samples.

  • There's something strange happening here. In over 2 years of using BM3 daily I don't even have a /Var/ folder!

    for me, if I record or edit samples in an unsaved project, they get saved in 'Unsaved sessions' in a folder named with the current date (something like 'Unsaved session 22-01-2020')
    If I record or edit samples in a saved session, they get stored in the project folder.

    I don't have any 'Var' or 'Mobile' folders!

  • edited January 24

    @tk32 :

    It looks like this path is the System path to /var device folder.
    I think it is used by BM3 as the temp directory, where the BM3 temporarily saves edited audio.

    I did some search and found that this is the kind of iOS error.

    It can be found on various iOS programming resources.
    The one of for example:
    https://forums.xamarin.com/discussion/144467/show-image-from-var-mobile-containers-data-application-path

    Normally, user has no access to this path (only iOS devices with jailbreak can, but it is bad idea, absolutely).
    It looks like really important to save a Bank, after editing the file.

    I preferred to save the file immediately after editing, with enabling all folders options.

  • OK thanks.
    Strangely enough some sliced samples are found just as they should.
    And this single sample (last video) should have been found as normal, I believe.

  • @pask74 said:
    OK thanks.
    Strangely enough some sliced samples are found just as they should.
    And this single sample (last video) should have been found as normal, I believe.

    Yes, it is interesting. I hope I will catch the sequence of actions once.

    btw. My workflow is based on "save it as soon as possible". :)
    It is not about the BM3, this is kind of a habit over the years.
    I often record, sometimes I record other guys, so it's very important for me to keep takes and backups safe.

  • I’m also an audio engineer by profession and data management is part of my daily work. This is why a proper section on that topic is needed in the manual, in my opinion.

  • @StudioES said:
    Not sure if it's been mentioned yet but does deleteing & reinstalling BM3 help?

    After updating to iPadOS, I had a Files App issue where all content would disappear until the next reboot. Manually backing up BM3's content, deleting BM3, rebooting, reinstalling BM3, & restoring the backup fixed this, for me at least.

    I don't have the 'missing samples' issue, but I 'Save As...' checking all options often.

    I just do save as “copy samples” only

  • Most of the time I just hit Save As and don't select any of the options and have had luck so far. Unless of course it's a session where I want/need the samples to be embedded in the project.

    Also, are you always saving the Banks in each of these sessions?

    It does seem to be more of something happening when saving the slices, though. I think @roman_che has some good insight into whats happening.

  • @pask74 said:
    Even though I manually relink missing samples and save, these samples are lost on next re-open...

    Have you tried to see if you can reproduce the problem by starting with a new file and keeping notes about the precise steps followed. Screen recording an editing session (starting with a new clean session) that leads up to the problem might provide some clues. There must be some important nuance leading up to this -- otherwise, any of us that do slicing would be running into it.

  • edited January 30

    Haven’t been having these issues since I started employing the housekeeping tips in these videos:


  • This bug can be iPadOS13 also. This is why I wrote about "we will find it once", because I am not clearly sure what side is.

    I can only say, we need to catch the steps sequence.

    This bug is not only on bm3. Look here for an example please:
    https://github.com/apache/cordova-plugin-file/issues/346

  • For me it had to with moving folders/projects, also made a video back then..

    https://intua.net/forums/index.php?p=/discussion/7731/samples-grayed-out#latest

  • edited February 2

    Hey gang,

    Thanks all for your willingness to help, that’s much appreciated.

    My workflow is always the same:
    1. Create a new session
    2. Save the new session as...
    3. Sample some stuff from vinyl using the Arturia Audiofuse
    4. Save often, without saving samples each time as my understanding is it would create duplicate files and I’d like to stay disk space efficient.
    5. Close and reopen. This is when some files are missing some times.

    The strange thing is that in some instances everything is recalled just as it should.
    In some others, sliced samples are lost.
    In rare instances even single sounds (typically drum sounds from a library (=simple wav files) are also lost.

    I can’t identify a consistent scenario as we speak.

    I also found those 2 videos about file management and will stick to the suggested approach from now on.

  • @StudioES said:
    OP mentioned that he's interested in the MPC4000. It's worth mentioning that its OS is unfinished, broken, & will never be fixed - it's a nightmare ranking at the very bottom along with the ASR-X & Fusion. BM3 on its worse day is lightyears more reliable. Good luck.

    Interesting - that’s not what I’ve heard from users.
    I remember my ASR-X being atrocious (especially the sequencer) but the sound was huge.
    I’ve given it a quick test run the other day and I liked it’s punchy sound and the all-in-one package. Now, it’s 2020 and I want to believe that an iPad, a good audio/midi interface and controllers is at least an equally as good option both in terms of interface and sound.

Sign In or Register to comment.