Audiokit Digital D1 - Doesn’t Record In BM3

Hi All,

I recently purchased D1 Digital Synth by Audiokit Pro. It’s a great app, and a source for a lot of inspiring sounds. Unfortunately, when I try and record anything in BM3, the sounds quickly change tempo, synch, and general behaviour changes. This happens whenever the Play or Record buttons are pressed. I have no idea how to fix this issue. The issue is non existent when you’re just messing around and testing patches without playing against a metronome or recording.

I tried reinstalling the app but that didn’t work. The IAA also doesn’t work and gives me an error message every single time I try and load up an instance.

Any help here would be appreciated. I really want this app to work!

@analogMatt

Tagged:

Comments

  • What iOS version are you on?

  • Sounds like it could be caused by a samplerate mismatch. Try changing BM3's samplerate from 48khz to 44.1khz (or vice versa) and see if that solves some of the problems. Also check D1's audio settings.

    IAA is a bad technology, and has always been the source of annoying bugs and limitations. The sooner it is completely replaced with auv3, the better.

    It is no accident that the developer of NS2 chose not to support IAA at all. A smart decision, IMHO.

  • @cthulufunk said:
    What iOS version are you on?

    I’m on the latest version 13.2.3

  • @tk32 said:
    Sounds like it could be caused by a samplerate mismatch. Try changing BM3's samplerate from 48khz to 44.1khz (or vice versa) and see if that solves some of the problems. Also check D1's audio settings.

    I think you may have uncovered another issue for me. I can’t change the sample rate from 48khz to 44.1khz. When I go to change it, it doesn’t accept the change when I tap on 44.1khz. This is so strange.... Is there away around this or do I have to reinstall BM3?

    Thanks for your help, I really appreciate it.

  • @Novicane

    Perhaps it's because you are using an audio interface fixed at 48khz? or wireless headphones?

    It's also possible there is an IAA app in the background locking your ipad to 48khz. Try force quitting any ghost IAAs, or restarting the iPad

    and lastly, make sure that "high quality measurement mode" is OFF in BM3's settings.

  • @tk32 said:
    @Novicane

    Perhaps it's because you are using an audio interface fixed at 48khz? or wireless headphones?

    It's also possible there is an IAA app in the background locking your ipad to 48khz. Try force quitting any ghost IAAs, or restarting the iPad

    and lastly, make sure that "high quality measurement mode" is OFF in BM3's settings.

    All I'm using is the iPad dongle to connect my headphones (3.5m) and my DT 770 Pro Beyerdynamic headphones so that shouldn't interfere with the samplerate. I don't have any instances of an IAA loaded up, nor can I see any loaded up on any of the tracks. I still can't change 48khz to 44.1khz.

    I turned off the High Quality Measurement, but the audio issues still persist. A restart of the iPad did not fix this problem either. Here are my BM3 settings if that helps at all:

    Audio:

    Background Audio: On
    Output Sample Rate: 48000 Hz
    Latency: 512 sampes
    Recording Bit Depth: 24-bits
    High-Quality (Measurement Mode): Off

    Sync:

    Ableton: Off
    Midi Clock: Off
    Midi Clock Out: Off

    Midi:

    Input Devices:
    Power On - BeatMaker 3 - Sync (off)
    Power On - Network Session 1 - Sync (off)

    Output Devices:
    Power On - BeatMaker 3 - Sync (off)
    Power On - Network Session 1 - Sync (off)

    Again, I appreciate you problem solving this with me.

  • edited November 21

    This is a bit strange.

    I wonder if my good knowledgeable buddies @StudioES @mefisme and @samu may have any suggestions? (Or any of the other good friends I haven’t @‘d)

  • Latest iPad Pro? The DAC inside is locked at 48kHz when using the built-in speakers & USB-C>3.5mm adapter>headphones (3-pole plug). For 44.1kHz, either use headsets (4-pole plug) or an external audio interface.

  • On some iPad's it's simply impossible to select the 44.1k sample-rate unless using an external audio interface.
    I'm on an iPad Air 2, iPadOS13.2.3 and have no problems selecting 44.1k or 48k.

    As for the sample-rate problems they are a pita, some plug-ins ignore host-sample rate and use the hardware sample-rate that can cause problems such as 'out of tune' and 'cracking up' (when plug-in runs at 48k and host at 44.1k or vice versa).

    For now BM3 lacks a proper 'track freeze' so the suggestion I have here is to use the AUv3 version of D1, record the midi and then use an audio-track that records the output from the plug-in (using the bank/pad where the AUv3 us hosted as the source).

    For devices that lock the sample-rate to 48k the solution for now is to use an external audio-interface.

  • @StudioES said:
    Latest iPad Pro? The DAC inside is locked at 48kHz when using the built-in speakers & USB-C>3.5mm adapter>headphones (3-pole plug). For 44.1kHz, either use headsets (4-pole plug) or an external audio interface.

    Yes, I bought the latest iPad Pro. I don't know what a 4-pole plug is tbh... In the past I was able to change from 44.1 to 48 easily with the same set up of headphones. I have an amplifier for my headphones that I occasionally use which is the FIIO Portable Headphone Amplifier but using it or not using it still wont let me change 48khz to 44.1khz.

  • @samu said:
    On some iPad's it's simply impossible to select the 44.1k sample-rate unless using an external audio interface.
    I'm on an iPad Air 2, iPadOS13.2.3 and have no problems selecting 44.1k or 48k.

    As for the sample-rate problems they are a pita, some plug-ins ignore host-sample rate and use the hardware sample-rate that can cause problems such as 'out of tune' and 'cracking up' (when plug-in runs at 48k and host at 44.1k or vice versa).

    For now BM3 lacks a proper 'track freeze' so the suggestion I have here is to use the AUv3 version of D1, record the midi and then use an audio-track that records the output from the plug-in (using the bank/pad where the AUv3 us hosted as the source).

    For devices that lock the sample-rate to 48k the solution for now is to use an external audio-interface.

    I can't record anything because the sound while playing is so out of tune with the metronome that it screws everything up especially on patches that use an ARP. When I press PLAY or RECORD in BM3 the patches that use the ARP are delayed by a beat it seems or they just behave very strangely. I have tried to record directly into the sampler without pressing play but the tempo still doesn't line up.

    This really sucks.... I wonder if I have to reinstall BM3 altogether. There was a moment and time when I was able to switch sample rates. This is really frustrating and BM3 is nowhere to help. Damn


  • Here's how jacks for the iPhone & iPad are configured.
    If MIC pole is 'detected', it should allow switching to 44.1kHz.
    Your FIIO doesn't have a MIC input. Your DT770s are 3-pole.
    Try a set with a mic which will have a 4-pole plug, like the Apple EarPods which used to come with new iPhones.

    I recently tested:
    2015 iPhone 6s Plus: Speakers locked at 48kHz. 3-pole & 4-pole allows switching to 44.1kHz.
    2019 iPad Air 3 & Mini 5: Speakers locked at 48kHz. 3-pole locked at 48kHz. 4-pole allows switching to 44.1kHz.
    2018 iPad Pro 11 w/ USB-C>3.5mm: Speakers locked at 48kHz. 3-pole locked at 48kHz. Didn't test 4-pole.
    2018 iPad 6th Gen: Speakers allow switching to 44.1kHz or 48kHz. 3-pole allows switching to 44.1kHz or 48kHz.
    2017 iPad Pro 10.5: Speakers allow switching to 44.1kHz or 48kHz. 3-pole allows switching to 44.1kHz or 48kHz.
    2013 iPad Mini 2: Speakers allow switching to 44.1kHz or 48kHz. 3-pole allows switching to 44.1kHz or 48kHz.

  • Thanks > @StudioES said:

    Try a set with a mic which will have a 4-pole plug, like the Apple EarPods which used to come with new iPhones.

    I recently tested:
    2015 iPhone 6s Plus: Speakers locked at 48kHz. 3-pole & 4-pole allows switching to 44.1kHz.
    2019 iPad Air 3 & Mini 5: Speakers locked at 48kHz. 3-pole locked at 48kHz. 4-pole allows switching to 44.1kHz.
    2018 iPad Pro 11 w/ USB-C>3.5mm: Speakers locked at 48kHz. 3-pole locked at 48kHz. Didn't test 4-pole.
    2018 iPad 6th Gen: Speakers allow switching to 44.1kHz or 48kHz. 3-pole allows switching to 44.1kHz or 48kHz.
    2017 iPad Pro 10.5: Speakers allow switching to 44.1kHz or 48kHz. 3-pole allows switching to 44.1kHz or 48kHz.
    2013 iPad Mini 2: Speakers allow switching to 44.1kHz or 48kHz. 3-pole allows switching to 44.1kHz or 48kHz.

    Hey StudioES, thanks for the explanation. I actually learned something new today regarding 4 pole and 3 pole headphones. I found a pair with a mic that had a 4 pole plug (Bose SoundSport) and tested it with BM3. I still wasn't able to switch from 48Hz to 44.1Hz. Does that mean anything? I have a the iPad model MTXT2VC/A.

  • edited November 22

    Are you using the official Apple USB-C > 3.5mm adapter?
    Try to see if it can switch to 44.1kHz in other apps, like Audiobus 3, AUM, apeMatrix, NanoStudio 2, etc.
    MTXT2VC/A = 512GB 2018 iPad Pro 11

    I didn't test a 4-pole headset in the 2018 iPad Pro 11 using that Apple adapter. I did test 3-pole headphones & it was locked at 48kHz.
    If you could test further, & post your results, that would be appreciated.

  • Update - I decided to delete BM3 altogether and reinstall it. Once I did that, I was able to switch between 48khz and 44.1khz readily.

    I tested a pair of 3 pole headphones and 4 pole headset w/ mic and they both work in either sample rate and am able to switch between. D1 is now perfectly in sync with the metronome and not doing the funky timing thing it was doing before.

    Thank you to everyone on this thread for jumping in and trying to problem solve. I really appreciate everyone’s responses and hope that someone going through a similar challenge can see this. The solution to reinstall is less than ideal but at least it works right!?

    Thanks!

  • Hey, your'e the first person to achieve that! :wink:

    @StudioES said:
    Are you using the official Apple USB-C > 3.5mm adapter?

    I didn't test a 4-pole headset in the 2018 iPad Pro 11 using that Apple adapter. I did test 3-pole headphones & it was locked at 48kHz.
    If you could test further, & post your results, that would be appreciated.

    How are you plugging in the DT770s & Bose? You mentioned 'iPad dongle' but what is that? You mentioned the FIIO headphone amp, but is it a USB interface or just an amp?

  • Glad you can enjoy BM3 unhindered again @Novicane

    I know I'd be pretty annoyed if something affected my ability to make music with this mighty app.

    Thanks everyone who chimed in to help. This forum may be a little quieter lately, but there is a still a strong core of helpful and knowledgeable fans active. Thanks guys.

  • edited November 22

    Just caught/saw this thread - (thought it may have been ALink related)..

    ———-

    Anyway, (to whom it may concern), I don’t hear about this iOS feature that much, “Offload”, but I use it before ‘completely’ deleting an app with an issue.
    It has worked/helped many times (no every, but many), and saves my data/settings:

    ✌🏼

    ..
    King
    .
    P.S. if you want to, you can even reboot your device in between Offloading and Reinstalling.
    .

  • Really nice tip.

    Thanks @KING :+1:

  • Thanks @tk32

    @KING Wow... This is a pro tip!

  • Does anyone know how the OP was able to set his 2018 iPad Pro to 44.1kHz, when using his 'iPad dongle' (is that the official Apple USB-C > 3.5mm adapter)? With headphones with 3-pole plug?

    It was locked at 48kHz in my tests - I couldn't select 44.1 in any music app, so for the sake of 'science', it'd be helpful to know how he achieved this! Thanks!

  • So I bought D1. The arp & sequencer drift after a few measures when sync'd to BM3. Same in AUM, though not as noticeable. It's worse than Sunrizer, if anyone's keeping notes.
    2018 iPad 6th Gen & 2017 iPad Pro 10.5. iPadOS 13.2.3. Internal audio; 44.1kHz. No external peripherals.

Sign In or Register to comment.